iMovie HD 6 Hot Tips

If you're looking to get the most out of iMovie HD 6, here are some nifty tips and tricks that will have you editing like a pro. For maximum efficiency, use iMovie keyboard shortcuts to quickly accomplish many tasks.

Using Real-Time Video Effects

iMovie HD 6 features 30 stunning new video effects that you can add to your clips, edit, and preview clips with effects in real time right in the main window. There’s no waiting for effects to render; you’ll see the changes as soon as you make them (the final rendering happens in the background). iMovie HD 6 takes full advantage of Mac OS X Core Video, which uses the graphics processing unit (GPU) of the Mac for hardware acceleration. (Mac OS X 10.4.4 is required for real-time effects. Performance depends on your actual system configuration.)

To see all of the new effects:

  1. Click the Editing button.
  2. Click the Video FX button.
  3. Scroll down to Quartz Composer and then click the disclosure triangle to see the 30 new real-time effects.

Note: When you apply effects to your project, the Preview window displays some additional controls. To play the effect, click the play button; click the button again to stop the motion. Click the loop button (the circling arrows) to loop the effect. To clear an effect, click the delete (X) button. You can also click the checkmark button as a shortcut to apply the effect.

Copy Clips Across Multiple Projects

iMovie HD 6 allows you to open up to 10 iMovie projects simultaneously. If you want to copy your video and audio clips across multiple iMovie HD 6 projects, just open the projects and drag-and-drop or copy-and-paste the desired clips. Here's how:

  1. With your present project open, open another project (or projects) that contains the video and audio clips you want to copy.
  2. Select the clips that you want to add (hold down the Shift key to select multiple clips).
  3. Drag the selected clips from one project to the other or from the Edit menu, choose Copy (or press Command-C), select the project in which you want to add the clips, and choose Paste from the Edit menu (or press Command-V).

Using the New Ken Burns Interface

The Ken Burns effect (a pan and zoom effect) allows you to add video motion to your still photos, and iMovie HD 6 features some nice enhancements to the interface. The Ken Burns controls now sit on a floating palette and the Preview window has additional controls—just like the video effects mentioned above. To play the effect, click the play button; click this button again to stop the motion. Click the loop button (the circling arrows) to loop the effect. To clear an effect, click the delete (X) button. You can also click the checkmark button to apply the effect.

Ken Burns

Edit without Destroying Clips

iMovie allows you to edit video to your heart's content without permanently altering the files. This is known as non-destructive editing. Here are four ways to edit clips without destroying your files. (If you ever forget which clips you've trimmed, remember that untrimmed clips have rounded corners at both ends, while a trimmed clip displays a straight edge on any side that was altered.)

Direct Trimming—Need to shorten a clip? Just select one, position the pointer at either end, and drag toward its center. Dragging from the left side trims the beginning of the clip; dragging from the right side trims the end of the clip. The farther you drag, the more you trim. For precision editing, watch the preview window as you drag to see your exact edit point.

Here, we're trimming the end of a clip by dragging the right edge toward the left. The neighboring clip ripples with the edit to prevent a gap.

Rippling—This type of edit lets you insert or trim a clip and all other affected clips in the timeline will move automatically to accommodate the change. iMovie, by default, ripples clips. If you, say, trim a clip, all clips that follow it in the timeline will move to the left to fill the gap. To temporarily disable rippling (prevent other clips from moving), hold down the Command key as you perform an edit. Any timeline gap you create will appear as a black screen by default.

Overwriting—If you want to extend a trimmed clip and trim one of its timeline neighbors, rather than perform two edits, you can do both at once by overwriting a clip. Hold down the Command key to disable rippling, and drag to extend a clip over another, overwriting that portion of the underlying clip. To make clips push away from your selected clip (ripple), don't hold down the Command key.

Audio Trimming—You can have audio clips (dialog or music) display as audio waveforms in the timeline (from the View menu, choose Show Audio Waveforms) to help you visually see the audio as you edit it. However, you can also listen to the audio clip while you're trimming it by "scrubbing" the audio (manually playing sound by moving the playhead across a clip). Just select an audio clip, hold down the Option key, and drag the beginning or ending of the clip toward the center to trim the clip�the playhead will follow your movements. You'll hear the clip being played (though somewhat oddly) as you move your mouse.

Save Time with Quick Commands

In a rush? Here are a few tasks that can be accomplished by doing quick commands.

Export Clips Faster

Exporting clips and importing them into another application need not be a 2-step process. You can quickly export video and audio clips to other applications by simply dragging and dropping them from the iMovie clips pane, timeline, or clip viewer directly onto iDVD drop zones, QuickTime (or other applications), the Finder, or the Desktop. If you can't see both applications on your screen, use Exposé to switch between iMovie and your target application (see System Preferences for more on Exposé).

You can export clips from iMovie to QuickTime Player by simply dragging a clip onto the QuickTime Player icon in the Dock.

Use a Television for Real World Monitoring

To get a feel for how your movie will look when distributed, connect your Mac to a TV monitor for real-time editing and previewing on the final medium.

Get HD without an HDV Camcorder

You don't need an HDV camcorder to use high definition (HD) formats in iMovie HD 6 (720p or 1080i). Simply bring in your high-resolution photos from iPhoto and set them in motion with the Ken Burns effect.

Save to Optimize a Project

The more edits you make to an iMovie project, the more system resources it uses. To optimize your movie and reduce the amount of memory it requires, save your project often.

Rearrange Clips in the Timeline

Rather than spend a lot of time pondering the order of clips you'll drag to the timeline, drag them all in and rearrange them in there. You can easily rearrange clips by simply dragging a clip up from the timeline and dropping it into another location—you can even rearrange multiple clips simultaneously. You can also move clips back into the clip pane from the timeline.

You can easily rearrange clips in the timeline by dragging and dropping them wherever you want.

Create Multiple Cuts

Avoid second-guessing your editing work by saving multiple variations of your movie project. If you're satisfied with a saved project but want to play around with it a bit more without messing up your current cut, save subsequent changes using the Save As command. From the Edit menu, choose Save Project As and type a new name for your latest director's cut. And now with the ability to have up to 10 iMovie projects open at the same time, you can quickly and easily compare and contrast your work.

Enhance Audio Wave Visuals

You can increase or decrease an audio waveform's visual appearance by pressing the up or down arrow keys, respectively. This does not affect the volume—it only affects the zoom. (To view an audio waveform, choose Show Audio Waveforms from the View menu.)

Set Snapping for Precision Editing

iMovie HD features “snap lines,” which can help you locate precise video and audio frames both visually and audibly as you scrub through your movie while holding down the Shift key. They can help you locate audio breaks, bookmarks, chapter markers, and more. If you use them often, you can turn them on so they always appear. Here's how:

  1. From the iMovie HD menu, choose Preferences.
  2. In the Preferences window, click the General tab.
  3. Select the “Snap to items in Timeline” checkbox.

This is what a snap line looks like. You can also choose whether or not to have snapping play a sound effect.

Import Clips Straight to the Timeline

Now that editing clips in the timeline is easier than ever, you may prefer to have iMovie HD import clips right to the timeline instead of to the clips pane. Here's how:

  1. From the iMovie HD menu, choose Preferences.
  2. In the Preferences window, click the Import tab.
  3. Select Movie Timeline as the location to place clips.