do I need snow leopard to sync my iphone 5 to my macbook os x which I bought in 2009?

It won't let me sync my new iphone without the 10.6 version software.

Follow this Question

1 Answer from the Community

  • Best Answer:

    Yes. I had to install it on my MacBook I bought in '09

    Was this useful? Answer 1

    8 of 9 people found this useful

Similar Questions

See more Similar Questions