Can I update from 10.4 to OS X Lion (10.7), or do i have to update to OS X Snow Leopard (10.6) first?

Back To Product

Follow this Question

1 Answer from the Community

  • Best Answer:

    You have to update to 10.6 first assuming it can be supported. These are the specs for Snow Leopard:
    Mac computer with an Intel processor
    1GB of memory
    5GB of available disk space
    DVD drive for installation

    For many Macs that are running 10.4, it may have a Power G4 type processor, in which case you would only be able to go to OSX 10.5, Leopard which is hard to find. Best of luck!

    Was this useful? Answer 1

    7 of 10 people found this useful

Related Questions