ihave 1.83 ghz intel core duo can i up date my system so that i can update my safari? i have safari5.1

Back To Product

Follow this Question

2 Answers from the Community

  • Answer

    No, you would need at least a core 2 duo processor.

    Was this useful? Answer 1

    3 of 4 people found this useful

  • Yes

    Was this useful? Answer 2

    0 of 1 people found this useful

Related Questions