Can I install Snow Leopard 10.6.3 on a late 2012 mac mini?

I keep getting an error, "You have “Install Mac OS X” 23.1.1.". My mac mini has an intel processor (2.3 GHz Intel Core i7). I am trying to go to a version of the OS that will run PowerPC applications.

Back To Product

Follow this Question

No Answers have been submitted

Be the first to answer this question.  Answer now

Related Questions