Can Leopard 10.5.8 work on my 2005 G5?/ (2)300Gb drives, 4Gb ram, 1.6 Processor(single), would like to know the best OS X platform to use, Ty.

My first Apple build, just would like to know the best platform to use for what I have, thanks.

Back To Product

Follow this Question

1 Answer from the Community

  • Leopard 10.5.8 is as far as you can go. If you even wanted Snow Leopard or Lion, you're out of luck as those operating systems require an Intel Core 2 Duo.

    Was this useful? Answer 1

    0 of 0 people found this useful

Related Questions