do i have to have mac os v 10.6 snow to run icloud?

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    You have to have 10.7 which is called Lion to be able to use the features that are included in iCloud.

    Was this useful? Answer 1

    1 of 1 people found this useful

Related Questions