Do you need to use Snow Leopard to use the Mac OS X App Store

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    Yes, you need 10.6.6 to use the App Store. If you click the apple in the top left corner and about this mac, you will see your version number. Here's a rundown:

    10.6 - Snow Leopard

    10.5 - Leopard

    10.4 - Tiger

    Snow Leopard requires an Intel Mac.

    Was this useful? Answer 1

    1 of 1 people found this useful

Related Questions