does osx 10.6.8 have icloud?

I want to use iCloud... I don't see it on my mac 10.6.4

Back To Product

Follow this Question

5 Answers from the Community

  • Best Answer:

    You need Lion (OS 10.7.2 or later).

    Was this useful? Answer 1

    177 of 215 people found this useful

  • you must have a os x lion on your mac to use icloud.

    Was this useful? Answer 2

    60 of 79 people found this useful

  • no, it does not have icloud.

    Was this useful? Answer 3

    14 of 22 people found this useful

  • no

    Was this useful? Answer 4

    22 of 40 people found this useful

  • yes

    Was this useful? Answer 5

    1 of 5 people found this useful

Related Questions