Hi I am running osx 10.4 which has Ical 2.0 I would like to update to Ical 3.0 or higher so that i can sync with G cal do I need to upgrade my os

Back To Product

Follow this Question

1 Answer from the Community

  • I have the same exact question, and need to upgrade iCal for the same reason (to synch with Google Cals)... and yes, it seems we need to upgrade OS, but from 10.4 to Leopard (10.5) or Snow Leopard (10.6)? Does anyone know what the best recommendation is?

    Was this useful? Answer 1

    0 of 0 people found this useful

Related Questions