Hi I have osx Lion on my mac but i think it is not compatible with parallels 6 so how do i downgrade it to snow leopard so that i can use parallels 6?

Back To Product

Follow this Question

No Answers have been submitted

Be the first to answer this question.  Answer now

Related Questions