How can I get 10.6.8 , the lower 10.6.X do not work with the Air Core I series?

Back To Product

Follow this Question

1 Answer from the Community

  • Go to Apple Menu and select "Software Update...". This will update to latest version of 10.6 (which is 10.6.8), if you are already running 10.6.x.

    Was this useful? Answer 1

    1 of 2 people found this useful

Related Questions