I am running 10.4.6 on my clamshell atm, is the snow leopard compatible for my mac?

Back To Product

Follow this Question

1 Answer from the Community

  • Hello there.

    Your mac has a PowerPC processor that is not compatible with Snow Leopard. To run Snow Leopard you need a newer Mac.

    Hope this helps.

    Was this useful? Answer 1

    0 of 0 people found this useful

Related Questions