i have a mac os x 10.5.8 processor 1.42 GHz powerPC G4 can i update the system?

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    Unfortunately, no.

    Beginning with OS 10.6 the Mac must have an Intel processor, not a PowerPC processor.

    Was this useful? Answer 1

    1 of 1 people found this useful

Related Questions