i have a power mac G4 will i be able to upgrade to snow leopard

Back To Product

Follow this Question

2 Answers from the Community

  • Best Answer:

    No! You will need a Macintosh with an Intel Processor in order to install Snow Leopard.

    Was this useful? Answer 1

    5 of 5 people found this useful

  • Unfortunately, no. Snow Leopard will only install and run on Intel multicore processors, and will not work on G5 or earlier processors like yours. Sorry!

    Was this useful? Answer 2

    4 of 4 people found this useful

Related Questions