I have an old iMac with the Version 10.5.8. If I buy Snow Leopard, can I download the newest OS for Mac?

Back To Product

Follow this Question

1 Answer from the Community

  • Depends if you have a PowerPC processor or an Intel Processor.

    If PowerPC you can not go past OS10.5.8.

    If Intel processor, you can install Snow Leopard. Once installed and updated to OS10.6.8, and depending on your hardware and memory, you can upgrade directly to any later version of the OS.

    However, if your iMac is running OS10.5.8 it is probably too old for the latest OS versions.

    Was this useful? Answer 1

    1 of 2 people found this useful

Related Questions