I have G5 PowerMac - powerpc 970 (2.2) - OS 10.4.11, so I can't update to snow leopard?

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    No you need an Intel based Mac for it to work.

    Was this useful? Answer 1

    3 of 3 people found this useful

Related Questions