i have iworks 08 do i need to upgrade to 09 to use snow leopard

Back To Product

Follow this Question

2 Answers from the Community

  • Best Answer:

    No you do not need to upgrade to iWork 09 to use Snow Leopard.

    The neat thing about updating your iWork software is the new and intuitive things the newer software has to offer, but Snow Leopard and iWork 08 should work just fine together.

    Was this useful? Answer 1

    8 of 9 people found this useful

  • No.

    Was this useful? Answer 2

    2 of 2 people found this useful

Related Questions