I have mac os x version 10.3.9 can I upgrade with macos x 10.6 snow leopard

Back To Product

Follow this Question

2 Answers from the Community

  • Best Answer:

    If you are running 10.3.9, your computer is likely a (check system Profiler) PPC, and thus, cannot run snow leopard (for it is for intel macs). However, it might be able to run leopard, which is an older release that can be purchased on ebay or amazon.

    Was this useful? Answer 1

    5 of 6 people found this useful

  • Yep. As long as your Mac has met all the system requirements for Mac OS X 10.6 Snow Leopard.

    Was this useful? Answer 2

    4 of 10 people found this useful

Related Questions