I have mac os x version 10.5.8 can I grade for Snow leopard

Back To Product

Follow this Question

2 Answers from the Community

  • Best Answer:

    The answer is most likely yes, unless your Mac is an older one with a PowerPC processor. Mac OS X 10.5 Leopard supports both Intel and PowerPC processors, but Mac OS X 10.6 Snow Leopard only supports Intel processors.

    To be sure, select "About This Mac" from the Apple menu. In the window that appears, if Intel is mentioned under "Processor", you're good to go. If it says PowerPC G4/G5, your Mac is not supported.

    Was this useful? Answer 1

    12 of 12 people found this useful

  • you need an intel cpu

    Was this useful? Answer 2

    2 of 3 people found this useful

Related Questions