I have OS X 10.5.8 and I cant download the mac itunes store. Do I really have to buy the newest version?

Back To Product

Follow this Question

1 Answer from the Community

  • Yes, the Mac App Store requires Snow Leopard.

    Was this useful? Answer 1

    5 of 10 people found this useful

Related Questions