I have the (2008) iMac; OS X version10.5.4. This was a used iMac I purchased. Based on what I have read. I should start with Snow Leopard OS?

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    You need Snow Leopard (OS 10.6). After installing, do Software Update (under the Apple Menu) to bring it up to OS 10.6.8.

    Once OS 10.6.8 is running, there will be a new app on your iMac called "App Store". It is through the App Store app that one downloads and installs all later versions of the Mac OS. You can go directly from Snow Leopard to any later version.

    Note that only the latest version of the OS (currently the free Mavericks OS 10.9) will appear in the App Store. In order to download and install Lion (OS 10.7) or Mountain Lion (OS 10.8), one needs to go to the online Apple Store and purchase a redemption code, which then gives instructions on how to access and download these OS versions through the App Store.

    According to WikiPedia, the 2008 iMacs (Model ID: iMac8,1) will support all recent versions of the Mac OS, including the upcoming OS X Yosemite. (The Model ID can be found under the Apple Menu --> About This Mac --> More Info --> System Report --> Hardware Overview.)

    Note that Snow Leopard requires 1GB of memory on Mac. OS 10.7 through OS X Yosemite require 2GB of memory.

    Was this useful? Answer 1

    1 of 1 people found this useful

Related Questions