I have version 10.5.8, can I upgrade to el capitan or do I need to purchase snow leopard first?

Back To Product

Follow this Question

1 Answer from the Community

  • You must upgrade to Snow Leopard (and update Snow Leopard to OS 10.6.8) in order to upgrade to El Capitan.

    (OS10.6.8 and later includes the App Store app, which is needed to download and install later versions of the OS if available. Currently, OS 10.7, OS 10.8, and OS 10.11 are available, but OS 10.7 and OS 10.8 first require the purchase of a redemption code through the online Apple Store.)

    PLEASE NOTE: Check the specs of your Mac to make sure it is compatible with Snow Leopard and then with El Capitan. If your Mac has an Intel processor it is probably compatible with Snow Leopard. But your Mac may be too old to be compatible with El Capitan.

    Was this useful? Answer 1

    2 of 4 people found this useful

Related Questions