I run OS X v 10.4 have just bought a time capsule but it says i need v10.5 to back up automatically is ther an upgrade or do i have to pay for it

Back To Product

Follow this Question

1 Answer from the Community

  • Time Capsule is designed to work with Time Machine, which is a feature that was introduced with Mac OS X 10.5 Snow Leopard. You will need to purchase an upgrade for Mac OS X to be able to use your Time Capsule with Time Machine.

    Was this useful? Answer 1

    0 of 0 people found this useful

Related Questions