I'm running Mac OS X Tiger on my iMac (intel), is it still possible to upgrade to Leopard 10.5 only?

I have a lot of Adobe CS4 and can't afford to have the reported headaches of Snow Leopard with it. My macBook is running 10.5 and CS4 nicely.

Back To Product

Follow this Question

1 Answer from the Community

  • Stay with the version you have and give "Snowy" another six months or so and then check the forums for the answers you need........

    Was this useful? Answer 1

    3 of 7 people found this useful

Related Questions