I'm still on OSX 10.4, not tiger either (?). Want to bring it right up to date with the latest - what do I need to purchase?

Back To Product

Follow this Question

2 Answers from the Community

  • Best Answer:

    If its 10.4 it should be tiger I believe. Is your computer an intel processor or PowerPC? If its a PowerPC you are not going to be able to upgrade to snow leopard. If you need to check what you have go to your apple icon in the upper left hand corner, click on "about this mac", and "more info". If you have an intel then you will need to purchase the Mac Box Set in order to upgrade to snow leopard.

    Was this useful? Answer 1

    13 of 13 people found this useful

  • There are various requirements for Snow Leopard that you should make sure you have in order to get up to date.

    Make sure you have an Intel Processor on your computer, to check, click the apple in the top left corner, go to about this mac and verify you have an Intel Processor. If you do have an intel processor than proceed down this list.

    Make sure you have at least 1GB of RAM installed in your computer. This is the bare requirements for the computer. Optimal RAM installation is 2GB but 1GB will suffice. If you don't have at least 1GB or want to upgrade to 2GB, take your computer to an Apple Service Center or local Apple Store. RAM is the cheapest way to speed up your computer.

    If you meet the above requirements than you can look into purchasing the Mac Box Set, which is a collection of Software that apple makes to allow you to get up to date on your computer. This will give you Snow Leopard (10.6), iWork 09 and iLife 09.

    Was this useful? Answer 2

    2 of 2 people found this useful

Related Questions