Most printers say compatible with 10.5x. Will they work on 10.6?

Back To Product

Follow this Question

1 Answer from the Community

  • Most Printer Drivers are being updated for Snow Leopard. HP, Canon and many other printer companies have updated their software for Snow Leopard. From my experience with customers upgrading to 10.6, printers have worked seamlessly. For more information about your specific printer, you should check out the companies website to check for updated software and drivers.

    Was this useful? Answer 1

    1 of 2 people found this useful

Related Questions