my mac g4 1.33ghz is 10.3.9 what is the most i can up date my software to

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    Snow leopard is Intel Compatible only, Sorry, the last you could upgrade to is Leopard. you might want to try resellers for old stock of leopard.

    Was this useful? Answer 1

    1 of 1 people found this useful

Related Questions