My macbook pro runs mac os 10.5.8 software and I need to upgrade to mac os x snow leopard. If my mac has 2 gb memory will snow leopard work?

My macbook is from 2010-2011 and it has never been updated since mac os 10.5.8.

Back To Product

Follow this Question

2 Answers from the Community

  • Answer

    Yes it will work. Snow Leopard requires a minimum of 1GB of memory.

    I am surprised your "2010-2011" MacBook Pro has OS 10.5.8 on it.
    Apple usually updates OS on new Macs as soon as a new OS is released.
    Snow Leopard (OS 10.6) was released on August 29, 2009.
    Lion (OS 10.7) was released on July 20, 2011.

    Was this useful? Answer 1

    3 of 3 people found this useful

  • The minimum memory requirement for Snow Leopard is 2GB, so it should work if your Mac meets all the other requirements. Snow Leopard was first released in late 2009, so any Mac from 2010 or later should meet the requirements.

    Was this useful? Answer 2

    1 of 1 people found this useful

Related Questions