what do i need to run icloud

Back To Product

Follow this Question

1 Answer from the Community

  • iPod Touch 3rd or 4th Gen
    iPhone 3gs, 4, 4s
    Mac OSX Lion

    Was this useful? Answer 1

    3 of 6 people found this useful

Related Questions