can airport extreme run on mavericks?

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    AP Extreme requires OSX 10.7.5 and Airport Utility 6.3 to set up. If you have Mavericks, you should be compatible with AP Extreme.

    Was this useful? Answer 1

    2 of 3 people found this useful

Related Questions