Is this Magic Trackpad 2 suitable for use with the MacBook Pro late 2011 models please/

Back To Product

Follow this Question

1 Answer from the Community

  • Magic Trackpad 2 will work with Macs running El Capitan and later, and only on Macs with Bluetooth 4.0 and later.

    To check your version of Bluetooth:
    1. Apple Menu, About this Mac
    2. System Report
    3. Bluetooth from the left
    4. Look for LMP version and see if it is 4.0

    Was this useful? Answer 1

    1 of 2 people found this useful

Related Questions