What features are lost, or will this work at all on a iMac with bluetooth 2.1 + EDR? Standard on mid-2010 iMac 3.2 Core i3 27".

Back To Product

Follow this Question

1 Answer from the Community

  • The product page specifies a Bluetooth 4.0 requirement. However, it does work via lightning cable with Bluetooth off, but the trackpad must be powered on. This trackpad works over Bluetooth with my 2007 iMac, so I would think anything newer than that would be fine. Having said that, I can confirm that my 2007 iMac has Bluetooth > version 4.0, so you may need to make sure your system is fully updated if you wish to use the trackpad over Bluetooth.

    Was this useful? Answer 1

    0 of 1 people found this useful

Related Questions