The requirements for this printer call for Mac OS X v10.6.8. My version is 10.10.2. Is the printer compatible with this version also?

Epson Expression Home XP-420 Small-in-One Printer

Epson Expression Home XP-420 Small-in-One Printer

Product No Longer Available

No Answers have been submitted