can I upgrade from 10.6.8? want to use icloud

Back To Product

Follow this Question

1 Answer from the Community

  • Best Answer:

    It's great that you have 10.6.8 and you can use it Lion if your Mac meets the hardware requirements. You need to have a Core 2 duo, I3, I5 or I7 processor, 2GB of RAM and 7GB of free space on your HD. If you've got that you're good to go.

    Was this useful? Answer 1

    5 of 5 people found this useful

Related Questions