Will OS X Lion 10.7 work on my older MacBook4,1.

2.1GHz Intel Core 2 Duo
4GB 667MHz DDR2
3MB L2 Cache.
- Currently Running 10.6.8

Back To Product

Follow this Question

1 Answer from the Community

  • Best Answer:

    Yes, Lion 10.7 will work on Macbook 4,1 (Early 2008 White Macbook). I have the exact same Macbook / ram / 10.6.8 as you and have felt increasingly compelled to purchase and install 10.7, mainly for security concerns, as it is still supported by Apple as well as Java security updates, and also 10.7 will run the still-supported Safari 6, unlike 10.6 which is stuck with Safari 5 and it's gaping security holes. Firefox 30 is great but I will also use Safari 6 if I install Lion.

    Was this useful? Answer 1

    72 of 74 people found this useful

Related Questions