I have a Mac OS X 10.5.8, Processor 1Ghz PowerPC G4 can I still upgrade with Snow Lepoard 10.6, and if I do will it affect any programs?

Back To Product

Follow this Question

4 Answers from the Community

  • Best Answer:

    No. Snow Leopard requires an Intel processor. 10.5.8 is the end of the operating system line for PowerPC Macs.

    Was this useful? Answer 1

    24 of 28 people found this useful

  • Unfortunately, Snow Leopard can not be used on a PowerPC G4. You must have an Intel-based Mac.

    Was this useful? Answer 2

    10 of 15 people found this useful

  • You cannot upgrade to due to Snow Leopard requiring an Intel processor.

    Was this useful? Answer 3

    6 of 10 people found this useful

  • so what i can do????pls.give good adv.

    Was this useful? Answer 4

    5 of 11 people found this useful

Related Questions