Can any of these new iPods run on an older Mac system, version 10.5.8?

1 Answer from the Community

  • No, iPods run iOS, an Operating System for iPod,iPad, and iPhone.

    • Answered by Mikail K from Westminster
    • Jun 11, 2013