Will the new iPods work with G4 processors?

and: Which versions of Mac OS will they work with>

1 Answer from the Community

  • Answer

    I'm guessing you mean the PowerPC processors in older macs, I myself have one of these machines (running Mac OS 10.4.11 and iTunes 9.1.2)and the newest iPod Nano I can sync is the 5th generation. iPod touch 4th generation doesn't work with this version of iTunes. In short no, anything new won't work.

    • Answered by Ianto H
    • Aug 30, 2013