I have mac pro with OS 10.6.8. What do I have to update to be compatible with iMovie11?

1 Answer from the Community

  • Answer

    Update your Mac Pro to OS 10.10.1 to move forward.

    • Answered by Wilkie J
    • Nov 25, 2014