• 2.0 out of 5 stars

    Yeti Pro on El Capitan

    As someone else has also mentioned, the Yeti Pro stopped working after I updated to El Capitan. I think this is unacceptable. Either Apple should have left the driver alone when they came up with El Capitan or Blue should have updated a driver for El Capitan. I contacted Apple and they blamed Blue for not updating the driver for the mic. I have contacted Blue but I am still waiting for a response in regards to my inquiry. I would have expected this from Microsoft but not Apple, it is very disappointing.

    12 of 14 people found this useful

  • 2.0 out of 5 stars

    Not My Best Mic

    I have not been able to fix the problem of this Blue Yeti Pro mic constantly dropping and reconnecting in Garage Band. I know many people have this same problem and try various fixes. Some work some don't. Mic works fine in Audacity though. I just bought a new iMac 2015 and the Blue Yeti still drops and reconnects constantly.

    This was a gift so I will just store it away with other devices that don't work, but for those considering a purchase here, I'd be a little cautious about connecting this USB mic to iMac.

    5 of 6 people found this useful

  • 2.0 out of 5 stars

    Only Works Intermittently With El Capitan

    The mic worked for awhile when I got it, but in the middle of testing settings in Garageband it just disconnected and will not reconnect. Trying different usb ports MAY work but only for awhile. Using a different cable is the same. This is apparently an issue with USB bugs in El Capitan. I've been seeing the same reports since last year, so god only knows when these people will even MENTION that there's a problem. Good luck.

    3 of 3 people found this useful

  • 2.0 out of 5 stars

    Not working in El Capitan

    Fantastic audio quality. Unfortunately not working for more than a few minutes in El Capitan due to Apple's USB bugs. Sound recorder works for a minute or two then just records static. Garageband does the same. Randomly disconnects and disappears from system profiler. Works perfectly under Yosemite though.

    2 of 2 people found this useful