Compressor 3 Release Notes

Introduction

Updated versions of Release Notes may be published as new versions of Compressor are released or new information becomes available. You can check for updated information by choosing Help > Release Notes when Compressor is open.

For the latest information about product updates, tips and techniques, and qualified third-party devices, visit the Compressor website at http://www.apple.com/finalcutstudio/compressor.

For the latest support information from AppleCare, choose Compressor Support from the Compressor Help menu. To receive automatic notification about new support issues, use Safari to bookmark the AppleCare Compressor RSS page at feed://docs.info.apple.com/rss/compressor.rss. See Safari Help for more information about configuring RSS feeds.

To join with other Compressor users in discussing issues related to using Compressor, visit the Compressor discussion website at http://discussions.apple.com/forum.jspa?forumID=999.

Compressor 3.0.5 Release Notes

This section contains release information about Compressor 3.0.5.

Using QuickClusters and Back to My Mac on the Same Computer

The QuickCluster feature of the Apple Qmaster distributed processing system is a simple and automated alternative to creating and configuring clusters manually. In previous versions of Compressor, enabling the Back to My Mac feature in Mac OS X v10.5 Leopard would remove any existing QuickClusters. This issue has been resolved. For more information about QuickClusters, see the Distributed Processing Setup guide.

Compressor 3.0.4 Release Notes

This section contains release information about Compressor 3.0.4.

Missing Clusters and Services Issue Resolved

Compressor 3.0.4 and Apple Qmaster 3.0.4, together with the Mac OS X v10.5.5 update, resolve an issue in which clusters were not visible in Compressor and Batch Monitor, and Compressor services did not appear in the Apple Qmaster pane of System Preferences.

Compressor 3.0.3 Release Notes

This section contains release information about Compressor 3.0.3.

Anamorphic Pixel Options for Apple TV

Compressor now includes options to create media files for Apple TV with anamorphic (non-square) pixel aspect ratios. The pixels are scaled by Apple TV to fit the intended aspect ratio during playback.

In Compressor 3.0.3, an additional item appears in the Device pop-up menu of the H.264 for Apple Devices Encoder pane:

Apple TV SD (Anamorphic)

You can choose this option to create an output media file with an anamorphic (non-square) pixel aspect ratio. The choice you make in the Device pop-up menu determines the set of possible options in the subsequent Aspect Ratio pop-up menu.

To create Apple TV media files with anamorphic (non-square) pixel aspect ratios:

  1. Apply an Apple TV setting to a job in the Batch window.
  2. Select the target in the Batch window.
  3. In the Inspector, open the H.264 for Apple Devices Encoder pane.
  4. In the Device pop-up menu, choose Apple TV SD (Anamorphic). The setting in the Aspect Ratio pop-up menu is selected automatically.

    Note: For the best results, it is recommended that you use the automatic mode for this Aspect Ratio setting. The automatic mode for the Aspect Ratio setting has a wider range of values to better match the source video (with the values determined and displayed when this output format is applied to a source media file).

  5. Optionally, you can manually choose a specific frame aspect ratio/pixel dimension combination by doing the following:
    1. Disable the automatic mode for the Aspect Ratio setting by clicking the Automatic button.

    2. Choose a frame aspect ratio/pixel dimension combination from the Aspect Ratio pop-up menu.

    Note: In some cases, the frame aspect ratios will be different, though the pixel dimensions are the same. This is because the pixel aspect ratios differ.

For more information about using the H.264 for Apple Devices Encoder pane, see the Compressor User Manual.

Dolby Digital Professional AC-3 Audio for Apple TV Output

In Compressor 3.0.3, the H.264 for Apple Devices Encoder pane has a checkbox that allows you to include Dolby Digital Professional (AC-3) tracks (with 5.1-channel surround sound) in output media files intended for Apple TV playback.

Important: The checkbox is available only on computers that have Mac OS X v10.5 Leopard.

To include Dolby Digital Professional (AC-3) tracks in Apple TV output media files:

  1. Apply an Apple Devices setting to a job in the Batch window.
  2. Select the target in the Batch window.
  3. In the Inspector, open the H.264 for Apple Devices Encoder pane.
  4. In the Device pop-up menu, choose an Apple TV option. As long as your computer has Mac OS X v10.5 Leopard installed, a checkbox named Include Dolby 5.1 will appear at the bottom of the pane.
  5. Select the Include Dolby 5.1 checkbox.

The output media file will include a Dolby Digital Professional (AC-3) track in addition to the default AAC audio track. The Dolby Digital Professional track will have 5.1-channel surround sound (five discrete channels plus a sixth channel for low-frequency effects).

Note: The contents of the Dolby Digital Professional (AC-3) track are dependent on the contents of the source media file. For example, if the source media file has stereo audio, the AC-3 track will contain the Left and Right channels from the source file, plus four silent channels.

For more information about creating output media files containing Dolby Digital Professional (AC-3) audio, see the Compressor User Manual.

Important: To test the Dolby Digital Professional (AC-3) track, you must play the output media file on an Apple TV that is connected (via optical cable) to a Dolby decoding sound system. In any other configuration, Apple TV will play the stereo AAC audio track.

Installing Compressor 3.0.3 and Apple Qmaster 3.0.3 with Existing Clusters

The Compressor 3.0.3 and Apple Qmaster 3.0.3 updates may disable any existing clusters you have configured.

To install the Compressor 3.0.3 and Apple Qmaster 3.0.3 updates with existing clusters:

  1. Take note of the computers that are currently a part of your cluster.
  2. Delete the cluster.
  3. Install the updates.
  4. Re-create the cluster.

Audio Speed Limits in Frame Controls

When you use the Frame Controls retiming controls to change the video speed, Compressor also adjusts the audio portion of the output media file so that it stays in sync with the video. However, the audio remapping range is 25 percent to 400 percent of the source speed. In order for the audio to stay in sync with speed-adjusted video in the output media file, the speed must be no less than 25 percent of the source speed and no greater than 400 percent of the source speed.

Entering the Cluster Storage Location Manually

The following is a tip on how to enter the scratch storage location in the Apple Qmaster pane of System Preferences without having to navigate using the file browser.

To enter the cluster storage location manually:

  1. On the cluster controller, open the Apple Qmaster pane of System Preferences.
  2. If any Apple Qmaster services are enabled on this computer, click Stop Sharing to temporarily turn them off.
  3. Click Advanced to open the Advanced pane.
  4. Click the Set button next to the Cluster Storage field.
  5. Press Command-Shift-G. The text entry field appears.
  6. Do one of the following:
    • Type the file path into the field.
    • Copy the file path text from some other source and paste it into the field.

For more information, see the Distributed Processing Setup guide.

Compressor 3.0.2 Release Notes

This section contains release information about Compressor 3.0.2.

Mac OS X v10.5 Leopard Support

Compressor 3.0.2 is compatible with Mac OS X v10.4.11 and Mac OS X v10.5 Leopard.

Installing Compressor 3.0.2 and Apple Qmaster 3.0.2 with Existing Clusters

The Compressor 3.0.2 and Apple Qmaster 3.0.2 updates may disable any existing clusters you have configured.

To install the Compressor 3.0.2 and Apple Qmaster 3.0.2 updates with existing clusters:

  1. Take note of the computers that are currently a part of your cluster.
  2. Delete the cluster.
  3. Install the updates.
  4. Re-create the cluster.

Using Compressor Distributed Processing with Mac OS X Server v10.5

To use the Compressor distributed processing feature with Mac OS X Server v10.5 Leopard, you must manually enable NFS.

To enable NFS for Mac OS X Server, do one of the following:

  • Use the Server Admin application to enable NFS. For additional information, see Mac OS X Server Help.
  • In the command line, enter the following:
qmaster$ sudo nfsd enable

Color Tab in Inspector

The Filters pane of the Inspector now includes a Color tab for selecting and adjusting color space settings.

This tab is available for the following QuickTime output file formats only:

  • H.264
  • Apple ProRes 422
  • Apple Intermediate Codec
  • JPEG

To select a color space setting, choose one of the following from the Output Color Space pop-up menu:

  • Default for Encoder: Compressor chooses the output color space based on the dimensions of the output file.
  • Preserve source: Retains the color space of the source media file.
  • SD (601): Forces the output file to the ITU-R BT.601 (standard definition) color space.
  • HD (709): Forces the output file to the ITU-R BT.709 (high definition) color space.

Square Pixels Pop-Up Menu Item Is Now Called Correct for Pixel Aspect Ratio

In the Preview window, you can use the Preview scale selection pop-up menu to adjust the Preview screen size. The Square Pixels item in that pop-up menu is now called Correct for Pixel Aspect Ratio.

Compressor 3.0.1 Release Notes

This section contains release information about Compressor 3.0.1.

256 kbps Bit Rate for iTunes Plus Audio

Compressor now offers AAC audio encoding at 256 kbps for compatibility with the new iTunes Plus format.

Entering Pixel Aspect Ratios

You can use the Pixel Aspect pop-up menu in the Geometry pane of the Inspector window to set the pixel aspect ratio of the output media file. This forces the pixel aspect ratios to conform to specific formats. In addition to the standard set of pixel aspect ratios, you can now choose Custom from the pop-up menu and enter any value.

Importing Annotations

The Additional Information tab in the source media Inspector window allows you to view and edit a variety of metadata items for any source media file. The Add Annotations pop-up menu in that tab now includes an Import option, allowing you to choose a .mov or .plist file and import annotations from it. Also, Compressor now includes the following command line option for selecting a .mov or .plist file and importing annotations from it:

-annotations <filepath>

Automatic Center Cropping

In addition to the automatic (Letterbox) crop setting that detects image edges and enters crop values to match them, Compressor now includes the following options for automatic center cropping (in the “Crop to” pop-up menu in the Geometry pane of the Inspector window):

  • 4:3 (1.33:1)
  • 16:9 (1.78:1)
  • Panavision (2.35:1)
  • Europe Standard (1.66:1)
  • UK Standard (1.75:1)
  • Academy (1.85:1)

Note: The actual numeric crop values are determined once a target setting is applied to a job.

Setting a Poster Frame

Compressor now supports poster frames. The Modify Marker Settings pop-up menu in the Preview window now includes the following items:

  • Set poster frame
  • Go to poster frame
  • Clear poster frame

Double-Byte Language Issue Resolved

In Compressor 3.0, if the computer you were using to browse (view) clusters was set to run Mac OS X in a double-byte language (such as Chinese, Japanese, Korean, and most other Asian languages), clusters and services that had names using double-byte language characters were not visible. This issue has been resolved.

Podcast Marker Issue Resolved

You can use podcast markers to provide artwork (and URLs) for users to view as they play audio podcasts. In Compressor 3.0, if you added podcast markers to a source clip, they had to have names for their assigned artwork to appear. This issue has been resolved.

Specifying the Podcast Marker Size

You can now specify the image size for podcast markers in enhanced podcasts.

To specify the marker image size for a podcast setting:

  1. In the Video pane of the MPEG-4 Encoder pane, deselect the Video Enabled checkbox.
  2. Select the “Allow Podcasting information” checkbox at the bottom of the MPEG-4 Encoder pane.

    Note: By default, the Marker Image Size fields are in automatic mode. In this mode, Compressor sets the podcast marker image size to that of the largest source image.

  3. To specify a different image size, click the Automatic button (to the right of the Marker Image Size fields) and enter the width and height values.

iPhone Format Support

Compressor now includes support for iPhone-compatible formats.

User Interface Adjustments in the H.264 for Apple Devices Encoder Pane

The following adjustments have been made to the user interface of the H.264 for Apple Devices Encoder pane:

  • The Size menu has been renamed to Device menu to more accurately reflect its purpose. Its functionality remains the same.
  • The Include AAC Audio checkbox has been replaced by the Audio pop-up menu. The Audio pop-up menu includes the following options:
    • None: Excludes audio from the output media file.
    • 24 Kbps: Sets the audio bit rate to 24 kbps.
    • 128 Kbps: Sets the audio bit rate to 128 kbps.
    • 256 Kbps: Sets the audio bit rate to 256 kbps.

Compressor 3.0 Release Notes

This section contains release information about Compressor 3.0.

Podcast Markers Are Red in the Compressor Timeline

If you add podcast markers to a source clip, they appear as red in the Compressor timeline. Here is a complete list of marker colors:

  • Red: Podcast marker
  • Purple: Chapter marker
  • Blue: Compression marker
  • Green: Edit/cut marker

Note: This information is not included in the Compressor User Manual.

Podcast Markers Must Have Names

If you add podcast markers to a source clip, they must have names for their assigned artwork to appear.

Note: Normally, the name does not appear to the viewer and is intended to help you organize your markers.

Why Are Some Compressor Windows Covered Up?

Because the Compressor interface is made up of individual windows, you may find that when you switch from Compressor to another application and then switch back to Compressor by clicking one of its windows, only that window appears, with the others remaining covered by other windows you might have open.

There are three ways to avoid this situation or to get all the windows to appear:

  • When switching between applications, take advantage of the built-in application switching feature of Mac OS X. Press Command-Tab to have an application-selection dialog appear. As you hold down the Command key, you can press the Tab key to cycle through the currently open applications, releasing the Command key once the Compressor icon is selected. This ensures that all the Compressor windows will be visible.
  • Choose Window > Bring All to Front.
  • Click the Compressor application icon in the Dock.

See the Compressor User Manual for details on using the new Compressor user interface.

About the History Window When You Submit a Batch

The History window now includes a transcode progress bar, controls to pause or cancel a transcode, and a Reveal in Finder control next to the completed output filename. For this reason, two changes have been made in what happens when you submit a batch:

  • By default, the Batch Monitor does not automatically open: The setting in Compressor preferences that determines whether the Batch Monitor automatically opens when you submit a batch is now off by default. You can change this if needed.
  • The History window automatically opens if it is closed: You can place the History window behind other Compressor windows, such as the Preview window, if you do not want it to appear when you submit a batch.

See the Compressor User Manual for details on taking advantage of these new History window features.

About Submitting Final Cut Pro Projects and Distributed Processing

When you submit a batch for transcoding that originated from a Final Cut Pro sequence and you are using distributed processing, Final Cut Pro must open on each of the cluster’s computers.

For best results, be sure Final Cut Pro is already open on the cluster’s computers. Compressor attempts to open Final Cut Pro (if necessary) on each computer in the selected cluster; however, if the External A/V Device warning appears, Final Cut Pro will not open and cannot be used. Additionally, when using the AutoCluster feature, be aware that submitting a batch will cause Final Cut Pro to open on the computers providing the unmanaged services, which might surprise whoever is currently using the computer.

See the Compressor User Manual and the Distributed Processing Setup guide for details on submitting Final Cut Pro jobs for distributed processing.

About the Preview Window and Final Cut Pro Projects

The Preview window does not respond when you try to view the Final Cut Pro sequence’s job after you have submitted a batch for transcoding that originated from a Final Cut Pro sequence. This is true even after the transcode has finished. However, once the transcode has finished, you can deselect the job that contains the Final Cut Pro sequence, then select it again to have the Preview window respond correctly again.

About the Preview Window and Chained Jobs

You can now chain the output of one job in a batch to another job in the same batch. This makes it possible to perform multiple types of transcodes on the source clip while controlling the order in which the transcodes happen.

You cannot preview the chained jobs, however. The Preview window shows a chainlink icon when you select the chained job in the batch.

Using Virtual Clusters to Make the Most of Multiprocessor Computers

If any of the service node computers in your network have multiple processors, you can adjust the number of instances of processing service, essentially creating virtual clusters on individual computers. For processor-intensive work, such as HD H.264 transcodes, having many instances of processing service may increase speed and efficiency, depending on the processing application. You may need to adjust the number of instances based on your particular workflow, but a good starting point would be one service for every two processors.

However, with large, complicated jobs, such as HD H.264 transcodes, your computer may not have enough memory to support multiple services running at the same time. In this case, your computer may become unstable. Be sure your computer has an adequate amount of RAM before configuring it to support running multiple services. A minimum of 1 GB of RAM per service is recommended.

Browsing Distributed Processing Clusters and Services in Double-Byte Languages

If the computer you are using to browse (view) clusters is set to run Mac OS X in a double-byte language (such as Chinese, Japanese, Korean, and most other Asian languages), clusters and services that have names using double-byte language characters are not visible in Compressor, Batch Monitor, Apple Qadministrator, or Apple Qmaster.

To make clusters and services visible, do one of the following:

  • Do not use double-byte language characters in cluster and service names, or in user names.
  • Set Mac OS X to English in the Language pane of the International pane of System Preferences.

Previous Cluster Appears Temporarily in the Compressor Cluster Pop-Up Menu

The Compressor menu includes an item named Reset Background Processing that you can use to reset processing services (current jobs are restarted from the beginning). After you reset processing services, the previous local cluster may appear temporarily in the Cluster pop-up menu in the Compressor submit dialog. This item will disappear from the pop-up menu when you select a different cluster.

About the Batch Monitor and Multiple Info Windows

When you are transcoding a batch using distributed processing, you have the option of opening an Info window for each segment that is being processed. Depending on your computer, you may find that the Batch Monitor performance degrades if you have multiple Info windows open.

See the Batch Monitor User Manual for more information.

Droplets Created with Previous Releases Must Be Re-created

Droplets you have created using previous releases of Compressor cannot be used with Compressor 3. You must re-create these droplets.

2008-10-08