Motion 3 Release Notes

Introduction

Updated versions of Release Notes may be published as new versions of Motion are released or new information becomes available. You can check for updated information by choosing Help > Release Notes when Motion is open. To download additional information from previous releases of Motion, go to http://support.apple.com/manuals/en/Motion_2.0_lbn_z.pdf.

For the latest information about product updates, tips and techniques, and qualified third-party devices, visit the Motion website at http://www.apple.com/finalcutstudio/motion and the Motion support site at http://www.apple.com/support/motion.

For the latest support information from AppleCare, choose Motion Support from the Motion Help menu. To receive automatic notification about new support issues, use Safari to bookmark the AppleCare Motion RSS page at feed://docs.info.apple.com/rss/motion.rss. See Safari Help for more information about configuring RSS feeds.

To join with other Motion users in discussing issues related to using Motion, visit the Motion discussion website at http://discussions.apple.com/forum.jspa?forumID=656.

Motion 3.0.2 Release Notes

Motion 3.0.2 addresses specific customer issues and general performance issues and improves overall stability.

Mac OS X v10.5 Leopard Support

Motion 3.0.2 is compatible with Mac OS X v10.4.11 and Mac OS X v10.5 Leopard.

50 fps Support

Motion 3.0.2 includes support for 50 fps frame rates. To activate 50 fps frame rates, open the Project Properties dialog, then choose Custom from the Preset menu. The Frame Rate pop-up menu now displays a 50 fps option. In addition, new presets have been added to support 50 fps projects.

Note: Final Cut Pro and Color now support 50 fps footage as well.

60 fps Drop Frame Support

Motion 3.0.2 includes support for 60 fps drop frame (59.94 fps) projects.

Note: Final Cut Pro and Color now support 60 fps drop frame as well.

Motion Master Templates in Final Cut Pro

The performance of Motion master templates used in Final Cut Pro sequences has been improved in the following ways:

  • Playback performance of master templates has been enhanced.
  • Master templates can be moved and scaled without causing rendering problems.
  • Master templates used in Final Cut Pro sequences with either mixed frame rates or frame rates that do not match the master template are no longer improperly scaled.
  • Field dominance settings are now correctly reported in PAL Final Cut Pro sequences containing master templates.
  • Printing to video now renders properly in Final Cut Pro sequences containing master templates with drop zones.
  • In Final Cut Pro, opening a master template containing drop zones that have been cut and pasted no longer causes Final Cut Pro to stop responding.

Motion 3.0.1 Release Notes

The following section contains information about Motion 3.0.1.

Flip Normal Option Is Now Available

When offsetting text on a path, the Flip Normal shortcut menu option allows you to flip the text on a per-curve-segment basis. On a path that contains four control points, for example, setting Point 1 to Flip Normal flips the text on the path between control points 1 and 2; flipping Point 2 flips the text on the path between points 2 and 3; and so on. To flip text on a path, Control-click the control point or the path segment, then choose Flip Normal from the shortcut menu.

Tracker Size Parameter Is Now Available

The Tracker Size parameter allows you to customize the size of the tracker region (represented by the magnified box that appears when you drag a selected tracker in the Canvas). Adjusting this parameter may assist you in achieving a better track. For example, use a smaller number to track a small, detailed pattern. The tracker parameters are located in the tracker controls section of the Behaviors tab in the Inspector. In the Inspector, click the track’s disclosure triangle to display the Tracker Size parameter.

Tracking with Camera May Slow Performance

Performing motion tracking in a project that contains a camera may result in slower than normal motion analysis. To speed the motion analysis, you can “solo” the object (the tracked footage) prior to tracking. When an object is soloed, the rest of the project scene is not rendered.

To solo an object, do one of the following:

  • Control-click the object and choose Solo from the shortcut menu
  • Select the object, then choose Object > Solo
  • Select the object, then press Control-S

3D Particles and Replicators That Intersect with Other 3D Particles and Replicators Are Not Anti-Aliased

Due to the significant performance impact, the following elements are not anti-aliased:

  • 3D particles (particles with the Render Particles parameter set to In Global 3D [Better]) that intersect with other 3D particles
  • 3D replicators that intersect with other 3D replicators
  • 3D particles that intersect with 3D replicators

Optical Flow Disk Space Management Is Now Available

The Reveal In Finder and Delete Retiming Cache buttons are now available in the Optical Flow Retiming section of the Cache pane in Motion Preferences (Command-comma). Because files generated by the Optical Flow Frame Blending option (in the Properties tab of the Inspector) may take up a large amount of disk space, these options allow you to quickly locate and remove the files.

Lighting Controls Have Been Removed from Non-Applicable Objects

Lighting controls in the Property tab of the Inspector are now only available for objects that can be affected. For example, lighting controls are available for a 2D group nested within a 3D group, but not available for the children of that nested 2D group.

Modifier Key Is Now Available When Drawing Shapes

You can now use the Command key when drawing shapes to create the shape in “local” space—in other words, in space that is “flat” to the image. By default, if you have rotated the camera and you draw a shape in a group, the shape is drawn in “screen” space and can intersect the other objects. Press the Command key when drawing shapes to draw the shape in local space so the shape retains the camera transforms of its parent group.

Performance Has Been Improved for Thin Shapes

Performance has been improved for projects that contain thin paint strokes. The minimum airbrush and Image Brush width is now set to 3. The minimum width for Solid brushes remains 1. Additionally, the onscreen controls (Command-dragging to define a width) have been restricted so that the minimum width matches the selected brush type.

Full Screen Mode Availability

Full Screen Mode (View > Full Screen Mode) is now only available for one project at a time. Motion exits Full Screen Mode if you create or open another project.

Fixed Known Issues

The following known issues have been fixed in Motion 3.0.1.

  • Scrubbing a retimed audio track while the Keyframe Editor is open no longer causes Motion to stop responding.
  • Applying certain third-party filters to Motion projects no longer causes Motion to stop responding.
  • Reordering the Point At behavior in a project no longer causes Motion to stop responding.
  • Applying an object to the Object well in the Zoom Layer camera behavior or deleting the Zoom Layer behavior from a project no longer causes Motion to stop responding.
  • Projects that contain the Directional Blur filter no longer stop responding upon quitting the Motion application.
  • Isolating a cloned Clouds generator with certain applied filters no longer causes Motion to stop responding.
  • Clicking tabs in the Timing pane after changing the location of a referenced audio file (in the Finder) no longer causes Motion to stop responding.
  • Motion no longer stops responding when a Group is applied to the Streak Map well for the Lens Flare generator.
  • Adjusting the duration of a text element in the Curves Steel Menu template no longer causes Motion to stop responding.
  • Dragging a replicator’s source object from the Layers list to the Brush Source well (in the Style pane of the Shape Inspector) of a paint stroke no longer causes Motion to stop responding.
  • Stability of Motion Tracking behaviors has been improved.
  • Exporting certain projects on a Mac Pro system (with NVIDIA or ATI graphics cards) no longer causes Motion to stop responding.
  • Dragging multiple filters from the Library to footage in the Layers list no longer causes Motion to stop responding.
  • Setting the Frame Blending parameter (in the Properties tab of the Inspector) for certain image sequences to Optical Flow no longer causes Motion to stop responding.
  • Stability when creating and animating shapes and paint strokes has been improved.

Motion 3.0 Release Notes

The following section contains information about known issues in Motion 3.0.

Fixed Known Issues

The following known issues have been fixed in Motion 3.0.

Audio Export

  • Exported audio now properly obeys keyframes.

Autosave

  • Restoring an autosaved project that contained an element using the Glow filter no longer causes Motion to stop responding.

Behaviors

  • Deleting a filter that has a Parameter behavior applied to it no longer causes Motion to stop responding.
  • Duplicating the Oscillate behavior no longer causes Motion to stop responding.
  • Adjusting the Drag parameter in the Align To Motion behavior no longer causes Motion to stop responding.

Color

  • The color picker now selects colors more accurately.

External Video

  • Projects no longer display the wrong aspect ratio when using a Kona 2 card.

File Browser

  • Scrolling through media in the File Browser no longer causes Motion to stop responding.

Filters

  • Applying the Kaleidoscope or Kaleidotile filter to an image mask no longer causes Motion to stop responding.
  • Adjusting the Front Size parameter in the Relief filter to a value greater than 8 no longer causes Motion to stop responding.

Layers List

  • Elements in the Layers list now resort correctly.

Preview

  • Switching applications while using full screen mode with Video Output set to Digital Cinema Desktop Preview no longer causes Motion to stop responding.

Shapes

  • Applying the Edge Collision behavior to either a shape or a group containing a shape no longer causes Motion to stop responding.

Motion Known Issues

The following section contains information about known issues in all versions of Motion 3.

3D and Lighting

  • The 3D grid may be affected by the blend modes of objects above the grid. For example, setting an object to the Stencil Alpha or Stencil Luma blend mode hides the 3D grid. The grid does not render with the project’s final output, so your final result is unaffected.
  • The 3D grid may be affected when an object’s Preserve Opacity checkbox is turned on in the Properties tab of the Inspector. The grid does not render with the project’s final output, so your final result is unaffected.
  • The Show Full View Area View menu option has no effect on rasterized groups with applied filters.
  • When an image mask (Object > Image Mask) is applied to a nonflattened 3D group, the mask is locked in Stencil mode. To use an image mask on a 3D group in a mode other than Stencil, select the group and turn on the Flatten checkbox in the Group Inspector.
  • Lights only affect 3D particle systems if “In Global 3D (Better)“ is chosen from the Render Particles pop-up menu in the Particles tab of the Inspector. 2D particle systems within a 3D group are affected by lights regardless of the Render Particles setting.

Backwards Compatibility

  • When opening a project that was created in a previous version of Motion, a dialog appears that allows you to either update and open the original project, or open the project as an untitled copy. Once the original project is opened and saved in Motion 3, it can no longer be opened in previous versions of Motion.
  • In Motion 3, changing the opacity of any group-type object (groups, particles, replicator, text, and so on) causes that object to be rasterized. Once rasterized, the entire object is faded as a single image. In Motion 1 and Motion 2, changing the opacity of text does not cause rasterization. Therefore, a project created in Motion 1 or Motion 2 that contains faded, overlapping text may appear different in Motion 3. To achieve the Motion 1 or Motion 2 results in Motion 3, use the Face controls in the Style pane of the Text Inspector to adjust the opacity of the text. Keep in mind that if you open an older project in Motion 3, then save that project, you may permanently alter your project.
  • What was formerly referred to as a “Layer” in previous versions of Motion is now called a “Group” in Motion 3 (in the Layers list, the Timeline Layers list, and the Inspector). Projects opened in Motion 3 that were created in previous versions of Motion still appear with elements named “Layer.” The “layer” object appears correctly in the Inspector as a “Group.” When a new Group is created, it is also named correctly as “Group” in the Layers list and Timeline Layers list.

Behaviors

  • Retiming behaviors are dependent on the order in which they are applied to footage. When using multiple Retiming behaviors, make sure the behaviors are arranged from bottom to top as well as left to right in the Timeline. For example, if you use a Hold Frame behavior that starts at frame 30 and ends at frame 60, followed by another Hold Frame behavior that starts at frame 80 and ends at frame 100, make sure the first behavior (for frames 30-60) is below the second behavior (frames 80-100) in the Layers list.

Templates

  • You cannot alter the built-in templates. However, because the Templates folder in /Library/Application Support/Final Cut Studio/Motion/Templates is Read/Write by default, you can add new templates and themes to that folder so that they can be accessed by multiple users on the same machine.

Shapes and Masks

  • Project interactivity slows dramatically when replicators and particle emitters (as well as groups) are used as brush sources for paint strokes.
  • The Apply Pen Speed, Apply Pen Tilt, and Apply Pen Pressure Shape behaviors can be applied to all shapes, including those that do not have any paint properties enabled. In these cases, the behaviors have no effect.
  • When Dynamics is enabled in the Advanced pane of the Shape Inspector, neither the Erase nor the Draw and Erase outline options in the Write On behavior will work. When you turn on Dynamics, the paint stroke dabs are moved away from the stroke; therefore, erasing the dabs over time is not allowed. When using Draw and Erase, the stroke draws but does not erase. This rule also applies to keyframing the First Point Offset parameter in the Style pane of the Shape Inspector.
  • When using a replicator, the By Rank option may appear in the Build Style parameters of the Replicator Inspector for certain 2D shapes when it is not applicable. This option should only be available with 3D replicator shapes. Selecting it will not perform any 3D action to a 2D replicator shape.
  • When using a preset Shape Style to create paint strokes, the appearance of some paint styles may change between drawing the stroke and completing the stroke. This is because Motion must calculate how the stroke will appear over the course of the entire stroke, which cannot be computed until the stroke is completely drawn.
  • Some paint strokes do not work with Write On enabled.

Keyboard Command Editor

  • The Up Arrow, Down Arrow, Right Arrow, and Left Arrow keys should not be remapped in the Command Editor.

FCP Integration

  • A video clip that is scaled up in Final Cut Pro may appear with a position pixel shift in Motion.

General

  • An image that is imported into Motion with an attached color profile and then exported from Motion may not match the originally imported image.
  • Dynamic Guides may not appear when Motion is first installed and opened. If Dynamic Guides do not appear by default, press the N key two times. The N key turns snapping on and off for the Dynamic Guides.
  • Retiming cache files generated by the Optical Flow Frame Blending option (in the Properties tab of the Inspector) may take up a large amount of disk space. By default, these cache files are stored in /Users/username/Documents/Motion Documents/Retiming Cache Files. If you have changed this location, display the Cache pane of Motion Preferences (Command-comma). The path to the files is displayed in the Optical Flow Retiming section of the Cache pane. You can remove older files from this folder. Any projects that reference these cache files are reset to use standard Frame Blending. If the location has been altered or you have chosen to store the files with the source media, you can remove the retiming cache files using the Finder. Retiming cache files are named with the name of the source media, a long unique ID string, and an “.mv” extension.
  • 16-bit and 32-bit float processing is not supported on graphics cards with 64 MB of memory. Addtionally, running multiple monitors using a 128 MB graphics card may be problematic.
  • When moving an object from one group to another, Motion adjusts the position and rotation values of the object so that it appears to stay in its original position and orientation. Alternatively, you can press the Command key when moving an object from one group to another to preserve the current position and rotation values. This may result in the object appearing to change position and orientation.
  • Pasting a media file from File Browser into the Media tab also places the object in the Layers list.
  • The Motion Command Editor now includes a Final Cut Pro command set. To load the Final Cut set, choose Motion > Commands > Final Cut Pro Set.
  • In the Library, some particle emitters do not display an interactive preview when you drag the pointer in the Preview Area.

Tracking

  • When using 32-bit files in a 32-bit project, the trackers do not function. You can track 32-bit footage in an 8- or 16-bit project. The default Stabilize behavior (with no manual trackers) does function in a 32-bit project.

Motion Known Issues with Workarounds

The following section contains information about known issues with workarounds in all versions of Motion 3.

  • The new Apple Keyboard (part number MB167LL/A) and Apple Wireless Keyboard (part number MB110LL/A) do not allow the use of the default Motion function key commands (F1, F2, F3, and so on). To use the default Motion function key commands on these keyboards, hold down the Fn key and press the appropriate numbered function key.
  • The Digital Cinema Desktop (DCD) Preferences (in the Output pane) may not properly initialize when Motion is launched. Press Command-F12 two times to enable DCD out, or choose a DCD option from the Video Output pop-up menu.
  • If any element in a project is cropped, and the project is exported in 32-bit mode, only the lower-left quadrant of the project is rendered. There are three workarounds for this:
    • Export the project in 16-bit mode.
    • Use a shape mask instead of crop to obscure part of an element.
    • Apply the crop to a group containing the element you wish to crop.
  • When the Adjust 3D Transform tool is selected in the Toolbar, pressing the S key to select the Select/Transform tool has no effect. To select the Select/Transform tool from the Adjust 3D Transform tool, press Shift-S.
  • The field order of the built-in PAL templates is set to lower first, which corresponds to PAL DV field order. If you are working in PAL Broadcast SD or D1 and want to use a built-in template, open the PAL template, choose Edit > Project Properties (Command-J), then choose Upper First from the Field Order pop-up menu in the Project Properties dialog.
  • Nested folders do not appear in the Template Browser. Although possible, it is not recommended to manually manage the built-in Templates folder. When creating templates and themes for templates, use the File > Save as Template command. This ensures the appropriate template folder structure. When moving templates from one computer to another, templates saved into subfolders of the Templates folder appear at the top level of a particular theme. For example, if you create a theme called “My Super Theme,” then manually copy several templates into subfolders within the “My Super Theme” folder, any templates within “My Super Theme” are displayed at the root level of the Template Browser. For more information on creating and saving templates, see the “Creating New Templates” section of Chapter 2, “Creating and Managing Projects” in the Motion 3 User Manual.
  • You can add new templates and themes to the Templates folder in the /Library/Application Support/Final Cut Studio folder. Motion is Read/Write by default. This means that you cannot alter the installed templates by default, but you can add new templates and themes to that folder so that the templates can be accessed by multiple users on the same machine.
  • If you render a RAM Preview or Export a project and then change the order of some layers or groups in the project, the original layer order is retained when you export again. To correct the problem, choose Mark > RAM Preview > Clear RAM Preview prior to exporting the project.
  • If you drag a Throw or Wind behavior to another object while the HUD is set to 3D, both the Zoom and Speed sliders appear in the HUD. Toggle between 2D and 3D modes to display the proper slider.
  • When using a graphics tablet and stylus for gesturing in Motion, and the Control key is selected as the gesture trigger, you cannot invoke contextual menus. To access the contextual menus using a stylus, you must use the barrel buttons on the stylus as the gesture trigger. To change the gesture trigger, select Pen Barrel 1 or Pen Barrel 2 from the Trigger pop-up menu in the Gestures pane in Motion Preferences (Command-comma).
  • If a shape is tracked to a source object with the Track Points behavior and the source object is transformed in 3D space, the shape does not follow the 3D transforms. For example, if you track a shape to a clip using the Track Points behavior and then rotate the source clip on the X axis, the shape follows the movement of the clip but does not rotate on the X axis. This is because the Track Points behavior tracks the vertices of a shape, and shape vertices cannot move in 3D space. To transform the shape with the transformed source object, apply a Match Move behavior to the shape (in addition to the Track Points behavior), and turn on the transformation you want to apply in the Adjust parameters of the Match Move behavior. Please note that this does not apply to masks. Masks follow the 3D transforms of their parent object.
  • Behaviors that use the Affect parameter may create unwanted animation when set to Related. This can happen in two circumstances:
    • You apply the Attractor, Drift Attractor, Repel, or Vortex behavior to a group at the same level as a camera.
    • You move a camera into a group containing an object with one of the above behaviors.
    To avoid unwanted camera or light animation, set the behavior’s Affect to Specific Objects, then drag the objects you would like to be affected into the list.

Corrections to Motion Documentation

The following section discusses documentation that is incorrect or information that has changed in the application since the Motion 3 documentation was written.

  • The Axis parameter description for the Align to Motion (Simulation) behavior on page 460 of the Motion User Manual states that the Axis parameter is “a pop-up menu that lets you specify whether the object aligns itself on its horizontal or vertical axis.” This should read “a pop-up menu that lets you specify whether the object aligns itself on the X, Y, or Z axes.”
  • The “Pal DV - Broadcast SD” project preset has been split into two different presets: Pal Broadcast SD and PAL DV. Screenshots in the documentation show the single PAL project preset “Pal DV - Broadcast SD.” This preset appears in the Preset pop-up menu of the Select Project dialog (when creating a new project), the Preset pop-up menu in the Project Properties dialog (Command-J), and in the Presets pane of Motion Preferences.
  • In the Library, the Content category’s directory structure has changed since the documentation screenshots were taken. As a result, certain screenshots may not have parity with the application.
  • The Drop Shadow parameters descriptions on page 312 and page 620 of the Motion User Manual do not discuss the Fixed Source checkbox. Motion 3 handles drop shadows differently than previous versions of Motion. If you open a project in Motion 3 that was created in a previous version of Motion, and that project contains a drop shadow that is rotating on the Z axis, turn on the Fixed Source checkbox to retain the drop shadow’s original effect (when the source object is rotated on the Z axis, the shadow also rotates in Z relative to the source object). When this checkbox is turned off, the drop shadow remains cast at the same distance and orientation regardless of the rotation and position of the source object.
  • The functions of the Left Arrow and Right Arrow keys are incorrectly described on page 247 of the Motion User Manual as collapsing and opening groups. In fact, the Left Arrow and Right Arrow keys perform the Previous Frame and Next Frame functions, respectively.
  • The Lens Flare generator is incorrectly described as a filter on page 973 of the Motion User Manual. The Lens Flare generator should not appear in the filters list on page 857 or in the index of the Motion User Manual on pages 1257 and 1266.
November 2, 2007