Soundtrack Pro 2 Release Notes

Introduction

Updated versions of Release Notes may be published as new versions of Soundtrack Pro are released or new information becomes available. You can check for updated information by choosing Help > Release Notes when Soundtrack Pro is open.

For the latest information about product updates, tips and techniques, and qualified third-party devices, visit the Soundtrack Pro website at http://www.apple.com/finalcutstudio/soundtrackpro.

For the latest support information from AppleCare, choose Soundtrack Pro Support from the Soundtrack Pro Help menu. To receive automatic notification about new support issues, use Safari to bookmark the AppleCare Soundtrack Pro RSS page at feed://docs.info.apple.com/rss/soundtrackpro.rss. See Safari Help for more information about configuring RSS feeds.

To join with other Soundtrack Pro users in discussing issues related to using Soundtrack Pro, visit the Soundtrack Pro discussion website at http://discussions.apple.com/forum.jspa?forumID=743.

Soundtrack Pro 2.0.2 Release Notes

This section contains release information about Soundtrack Pro 2.0.2. This maintenance release addresses performance issues and improves stability.

Mac OS X v10.5 Leopard Support

Soundtrack Pro 2.0.2 is compatible with Mac OS X v10.4.11 and Mac OS X v10.5 Leopard.

Audio Effects Issues Resolved

Soundtrack Pro 2.0.2 improves reliability of playback, exporting, and effects in projects that include processing effects and realtime effects. However, Soundtrack Pro 2.0.2 cannot automatically repair realtime effects issues in existing projects. To work around this, adjust the effect parameters and save the project in Soundtrack Pro 2.0.2.

Support for New Formats

Soundtrack Pro 2.0.2 includes support for 50 fps and 720p60 Final Cut Pro projects.

Soundtrack Pro 2.0.1 Release Notes

This section contains release information about Soundtrack Pro 2.0.1.

Setting Submix Outputs

By default, all submix outputs in Soundtrack Pro are set to Surround 1-6. This setting affects how audio signals are routed and how files are exported from multitrack projects. Use the Output pop-up menu in each submix to choose an output channel or set of output channels. Your choice defines the output of that submix (and any files exported from that submix) as either mono, stereo, or surround.

If you export a master mix using multiple submixes, the output channel or set of output channels of the first submix defines the channels used for the output of the exported file as either mono, stereo, or surround.

Delay Designer Interface Items

The following items regarding the Delay Designer effect plug-in user interface were not included in the Soundtrack Pro Effects Reference.

Tap Shortcut Menu

Control-click or right-click a tap in the Tap display to open the tap shortcut menu, which includes the following items:

  • 2 x delay time: Doubles the delay time (and therefore the speed) of all selected taps. For example, suppose the delay times of the taps are set as follows: Tap A = 250 ms, Tap B = 500 ms, Tap C = 750 ms. If you select these three taps and choose the “2 x delay time” shortcut menu command, the taps are changed as follows: Tap A = 500 ms, Tap B = 1000 ms, Tap C = 1500 ms. In other words, a rhythmic delay pattern unfolds half as fast. (In musical terms, this is often called playing in half time.)
  • 1/2 x delay time: Halves the delay time (and therefore the speed) of all selected taps. In the example above, choosing the “1/2 x delay time” shortcut menu command changes the taps as follows: Tap A = 125 ms, Tap B = 250 ms, Tap C = 375 ms. In other words, a rhythmic delay pattern unfolds twice as fast. (In musical terms, this is often called playing in double time.)
  • Delete tap(s): The “Delete tap(s)” command deletes selected taps.

Modifier Key Functions in Tap Display

Use the following modifier keys for the Tap display:

  • Press Option-Command to switch the Tap display to Level view. This allows you to quickly adjust a tap’s level.
  • Press Shift to bring the Overview display to the foreground. This makes navigation and zooming easier when the Overview display is partially obscured by taps.

Position of Tap Recording Bar

When you use the Tap pad to “record” taps, the tap recording bar appears in the Identification bar.

Delay Designer Sync Feature

Delay Designer can either synchronize to the project tempo or operate independently. When Delay Designer is in synchronized mode (Sync mode), taps snap to a grid of musically relevant positions based on note durations. For time-accurate taps in Sync mode, use Delay Designer as a realtime effect in the multitrack timeline. If you use Delay Designer as a processing effect or as a realtime effect in the File Editor project view, be sure to turn off Sync mode by clicking the Sync button.

Using Space Designer as a Processing Effect in Stereo

When you use Space Designer as a processing effect, it is possible to accidentally route the signal to channels other than the left and right channels.

To route signals to the left and right channels only:

  1. Open the Space Designer advanced settings window.
  2. Drag the Output C slider down to Mute.
  3. Drag the Balance slider up to Front (1.00).

The signals are routed to the left and right channels.

Exporting to Compressed Formats

If you export to compressed formats (MP3 or AAC) using devices that do not use class-compliant Core Audio drivers built in to Mac OS X, the audio track of the exported file may be silent. To avoid this issue, use the Audio MIDI Setup utility to change your default output audio device to Built-in or to a device that uses the class-compliant Core Audio drivers before exporting files.

Apogee Pro Control Panel

Soundtrack Pro includes a dedicated control panel that allows you to configure selected Apogee hardware. In some cases, some Apogee devices may not appear in the Apogee control panel. To work around this issue, use the Configuration Utility provided by Apogee.

Creating a Multichannel Clip by Combining Separate Clips

You can select up to 24 separate source clips in any one of the Soundtrack Pro media tabs (Bin, Browser, Search, or Favorites) and drag the clips to a track in the Timeline to create a single multichannel clip. The clips are combined in alphabetical order by filename (not in channel order using the channel tag in the filename). To ensure the correct channel order in the resulting multichannel clip, rename the source files so that they sort into the correct channel order, as illustrated in the table below.

Original source files

Renamed source files

filename-L

1filename-L

filename-R

2filename-R

filename-C

3filename-C

filename-LFE

4filename-LFE

filename-Ls

5filename-Ls

filename-Rs

6filename-Rs

iTunes Store Media Files

Soundtrack Pro does not support opening or importing any iTunes Store media files, including iTunes Plus files.

Soundtrack Pro 2.0 Release Notes

This section contains release information about Soundtrack Pro 2.0.

Importing AAF Files

Advanced Authoring Format (AAF) is an industry-standard project interchange format that Soundtrack Pro can use to share projects and import the editing decisions from third-party video and audio editing applications. Soundtrack Pro does not currently support embedded media in AAF files. When you export AAF files from other applications for use in Soundtrack Pro, make sure the exported AAF files use linked media (rather than embedded media).

Installing Audio Content

Soundtrack Pro 2 provides over 1000 sound effects (SFX), music beds, transitions, and more, enabling you to further add professional polish to your sound work. These professionally produced and recorded elements make it easy to get started quickly and keep the quality high.

By default, new Soundtrack Pro 2 audio content files are installed in the following location: /Library/Audio/Apple Loops/Apple/Apple Loops for Soundtrack Pro/.

A portion of the files installed with the Soundtrack Pro 2 audio content collection is simply CAF (Apple Core Audio Format) versions of the AIFF files that were installed with Soundtrack Pro 1.x. If you are upgrading, the Final Cut Studio installer will leave the AIFF files in their original location for project compatibility. You may have some applications installed that support Apple Loops files, but only in the AIFF format.

If you have any existing projects that use Soundtrack Pro 1.x audio content, it is recommended that you archive them to save both the project file and all audio files used by that project within the same location. After archiving your projects, you may want to delete the older AIFF files and switch to using the CAF versions. Instructions for archiving Soundtrack Pro projects (using the Collect Audio Files option) follow. You will need to follow a similar procedure for GarageBand, Logic Pro, or Logic Express projects.

To archive a project and its audio files together:

  1. Choose File > Save.
  2. In the dialog that appears, select the Collect Audio Files checkbox.
  3. Navigate to the folder in which you want to save the project and its audio files, then click Save.

The project file and a copy of every audio file the project uses are saved in the selected location.

To remove the original AIFF files that were installed with Soundtrack Pro 1.x:

  • Delete any existing Soundtrack Pro 1.x audio content files from the following folder: /Library/Audio/Apple Loops/Apple Loops for Soundtrack Pro/ (the default location) or the custom location you selected during your original installation.

    Note: If you use applications, such as GarageBand, Logic Pro, or Logic Express, that only support AIFF Apple Loops files, you may want to leave your Soundtrack Pro 1.x audio content files in place. However, you can save approximately 5 GB of disk space by removing AIFF files and using the CAF versions of those same files in your projects. The CAF files use Apple Lossless compression to retain the highest quality while reducing the space required to store them on your hard disk.

Once you have deleted the Soundtrack Pro 1.x audio content files and installed the Soundtrack Pro 2 audio content files, you may want to connect your existing projects to the corresponding Soundtrack Pro 2 audio content files.

To connect a project to corresponding Soundtrack Pro 2 audio content files:

  1. Open your project in Soundtrack Pro.
  2. If the Reconnect dialog appears, click Locate and navigate to the corresponding Soundtrack Pro 2 audio content files in the following location: /Library/Audio/Apple Loops/Apple Loops for Soundtrack Pro/.
  3. Click Open to reconnect the file or files.

The project and media file or files are reconnected.

If you skipped reconnecting the media when you opened your project, you can connect any offline files (labeled in red) using the Reconnect command. You can use the following steps to connect your project to corresponding Soundtrack Pro 1.x audio content or corresponding Soundtrack Pro 2 audio content.

To reconnect offline files:

  1. Find the offline media (labeled in red) in your project and do one of the following:
    • Control-click the clip or file in the Bin tab, then choose “Reconnect [filename]” from the shortcut menu.
    • Select the clip or file in the Bin tab, then choose “Reconnect [filename]” from the Media pop-up menu.
    • Select the clip in the Timeline, then choose Clip > Reconnect.
    • Control-click the clip in the Timeline, then choose Reconnect from the shortcut menu.
  2. Click Locate and navigate to the corresponding audio content files.
  3. Click Open to reconnect the file or files.

The project and media file or files are reconnected.

Using Space Designer with Looping Clips as a Processing Effect

If you apply effects using the Space Designer plug-in as a processing effect (by choosing Process > Effects > Reverb > Space Designer) to a looping clip that has a short duration, you may get unexpected results. To avoid this issue, make sure the duration of the looping clip is more than a half second.

Using Space Designer in Stereo

When you use Space Designer as a processing effect or a realtime effect, it is possible to accidentally route the signal to channels other than the left and right channels.

To route signals to the left and right channels only:

  1. Open the Space Designer advanced settings window.
  2. Drag the Output C slider down to Mute.
  3. Drag the Balance slider up to Front (1.00).

The signals are routed to the left and right channels.

Zoom to Cycle Region Keyboard Shortcut

In addition to zooming the view to the current selection (by pressing Option-Z), you can now also zoom the view to the cycle region by pressing Option-Control-Z.

Exporting to Compressed Formats

If you export to compressed formats (MP3 or AAC) using devices that do not use class-compliant Core Audio drivers built in to Mac OS X on Intel-based Macintosh computers, the audio track of the exported file may be silent. To avoid this issue, use the Audio MIDI Setup utility in the Utilities folder (/Applications/Utilities/) to change your default output audio device to Built-in or to a device that uses the class-compliant Core Audio drivers before exporting files.

Exporting a Master Mix

If you export a master mix using a submix or submixes set to output jacks that are greater than Mono 1, Stereo 1, 2, or Surround 1-6, the audio track of the exported file will be silent. To avoid this issue, change the submix output jacks to Mono 1, Stereo 1, 2, or Surround 1-6 before exporting.

User Manual Correction: Default Export Actions

On page 416 of the Soundtrack Pro User Manual, the bullet item titled “Send files to Audio Waveform Editor” should read “Send files to File Editor.”

November 2, 2007