Do all the apps in the App Store work with older models of iPod touches

Follow this Question

1 Answer from the Community

  • Answer

    No modern apps (ones that were created in 2017-2018) will be able to work on older iPods. However, for apps like Instagram and YouTube, the App Store will allow you to download an older version of the app, so technically you can still use most apps, they just won't be up to date.

    Hope this helps!

    Was this useful? Answer 1

    2 of 3 people found this useful

Similar Questions

See more Similar Questions