Have an iMac Mid 2007 with 2,4Ghz and 4GB SDRAM running Yosemite 10.10.5 new software purchase needs 10.11..will it run on this old computer?

Back To Product

Follow this Question

1 Answer from the Community

  • As per OS X El Capitan - Technical Specifications your iMac mid 2007 20" and 24" will work with El Captain!



    Was this useful? Answer 1

    0 of 0 people found this useful

Related Questions