Will this work with Iphone Xs Max ? if not where is the problem ?

  • Asked by fn
PROMISE Apollo Cloud 2 DUO Storage

PROMISE Apollo Cloud 2 DUO Storage

Product No Longer Available

1 Answer from the Community

  • Apple Responds

    System Requirements

    Operating System: Mac OS X v10.8 or later; iOS 8 or later, Windows 10/8/7/Vista, Android 4.0 or later

    • Answered by Salina E