Hi may I know that whether does it support Navision 2009 and above?

Recently I had purchased a mac and wanted to use it for work. Would like to know if I am able to install Navision 2009 and above on Parallels and run it.

Back To Product

Follow this Question

No Answers have been submitted

Be the first to answer this question.  Answer now

Related Questions