Is this device supported under ios 10.3?

I had a similar in concept device made by a different company at a much lower price. As soon as I upgraded the phone to IOS 10.3 the device was no longer recognized as compatible. Given the cost difference, I want to insure that this device will remain compatible

Follow this Question

1 Answer from the Community

  • Answer

    The Belkin Rockstar will work with iOS 10.3. It will work with any iOS device iOS 10 or higher.

    Was this useful? Answer 1

    2 of 2 people found this useful

Similar Questions

See more Similar Questions