why won't this Envy 7640 work with the current operating system yosemite 10.10?

I download the current operating system because it is recommended and my imac won't work with it using any of the current drivers. So I go to the Apple store and the all-in-one they recommend works with 10.9.

Back To Product

Follow this Question

No Answers have been submitted

Be the first to answer this question.  Answer now

Related Questions